Problema al subir archivo con com.FTPCliente.aix

Foro sobre App inventor. Te puedes registrar para colaborar y hacer preguntas.
SHAMROCK
Mensajes: 6
Registrado: Mar Jul 10, 2018 2:15 pm

Problema al subir archivo con com.FTPCliente.aix

Mensajepor SHAMROCK » Mar Jul 10, 2018 2:25 pm

Hola, he estado viendo el artículo sobre la extensión com.FTPCliente.aix
Todo funciona bien salvo que cuando quiero subir un archivo me da siempre FALLO EN LA SUBIDA...
No se que hago mal, pero básicamente
- me conecto al servidor FTP correctamente
- me cambio al directorio donde quiero subir una imagen (comprobado que estoy en ese directorio y los permisos estan correctos 0755)
- Llamo a la extensión ftp SubirArchivo poniendo en el parámetro srcFilePath una etiqueta que tiene el dato: file:///storage/emulated/0/Pictures/app_inventor_1234.jpg y en desFileName pongo el dato prueba.jpg


Alguien me puede ayudar?

Gracias!!

admin
Site Admin
Mensajes: 166
Registrado: Sab Ago 06, 2016 8:27 pm

Re: Problema al subir archivo con com.FTPCliente.aix

Mensajepor admin » Mar Jul 10, 2018 4:23 pm

Hola,
Ve al botón Crear un directorio en el directorio actual y pulsa para crear un directorio llamado: creame

Vas el botón Subir archivo al directorio actual
en el primer casillero pones
/mnt/sdcard/4.htm o bien el archivo que quieras subir
En el otro casillero
creame/4bis.htm

se subirá llamándose 4bis.htm

Dime si te funciona y si ves otros errores en esta extensión.
Saludos.

SHAMROCK
Mensajes: 6
Registrado: Mar Jul 10, 2018 2:15 pm

Re: Problema al subir archivo con com.FTPCliente.aix

Mensajepor SHAMROCK » Mié Jul 11, 2018 9:26 am

Hola, gracias por tu respuesta, pero no funciona...
Te adjunto imagen del bloque cuando tomo una fotografía.

El dato image es file:///storage/emulated/0/Pictures/app_inventor_1531300684274.jpg
El dato global FileName es app_inventor_1531300684274.jpg

Estoy en el directorio kunlabora (tiene los permisos 0755)
srcFilePath es el dato image
desFileName es el dato global FileName

Gracias por tu tiempo, quedo a la espera...
Adjuntos
Captura de pantalla 2018-07-11 a las 11.15.27.png
Captura de pantalla 2018-07-11 a las 11.15.27.png (129.21 KiB) Visto 33 veces

admin
Site Admin
Mensajes: 166
Registrado: Sab Ago 06, 2016 8:27 pm

Re: Problema al subir archivo con com.FTPCliente.aix

Mensajepor admin » Mié Jul 11, 2018 9:56 am

Hola, debes poner la dirección de esta manera

/mnt/sdcard/miarchivo.png

si está en la tarjeta externa, /mnt/sdcard2/DCIM/P454545-454545.jpg


Instala la aplicación ANDExplorer y mira cual es la dirección del archivo que quieres subir, debe empezar por /mnt/

SHAMROCK
Mensajes: 6
Registrado: Mar Jul 10, 2018 2:15 pm

Re: Problema al subir archivo con com.FTPCliente.aix

Mensajepor SHAMROCK » Mié Jul 11, 2018 1:22 pm

Al final ha funcionado !!!
Te cuento, segui tu consejo e instale ANDExplorer.
Ahí me di cuenta que a la ruta había que quitarle file:// y dejar solo lo que continuaba /storage/emulated/0/Pictures/app_inventor_1531300684274.jpg

Así que ahora esta OK!!, ya cuando termine la APP os avisaré y publicare un comentario.
Gracias por tu ayuda.


Volver a “Foro de App inventor”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 0 invitados